Major outage across our systems and products (Amazon AWS Outage)
Resolved
Nov 04 at 08:33pm ACDT
On October 17, 2025, PixelVerseIT experienced a service outage caused by a large-scale AWS regional failure affecting core infrastructure in the us-east-1 region. This incident impacted compute, storage, and networking resources used by many platforms globally.
What Happened
The AWS outage disrupted critical dependencies that our systems rely on.
- Application load balancing was interrupted, leading to intermittent timeouts and failed API calls across most of our services and platforms.
- Our websites became unreachable, returning HTTP 500 server errors for a significant portion of the downtime.
- We were unable to migrate services to other regions during the event because our hosting provider’s management dashboard was also affected by the same regional outage.
No customer data was lost, but service reliability and uptime were temporarily impacted.
How We Responded
Our team actively monitored AWS’s status communications throughout the incident. Once AWS restored internal control plane operations, we restarted core services and cleared queued background jobs. Normal operations were restored by 11:45 UTC. However, there were delays in deploying production updates once services were restored.
Next Steps and Reliability Improvements
To strengthen resilience and prevent similar disruptions, we are implementing a series of long-term infrastructure upgrades:
- Multi-region deployment: Core systems are being distributed across multiple regions and cloud providers, ensuring failover capability in the event of a regional outage.
- Cross-provider redundancy: We are expanding backup infrastructure to include alternative hosting platforms, reducing reliance on any single provider.
- Improved observability: Enhanced monitoring and alerting systems are being deployed to detect and respond to outages faster and more effectively.
Affected services
Updated
Oct 20 at 08:14pm ACDT
This incident is due to a AWS outage. We are working to resume services and are seeing a healthy reflection of traffic flowing.
Affected services
Created
Oct 20 at 06:25pm ACDT
We are currently investigating an third-party issue impacting most PixelVerse Systems and Products. Our team is actively investigating the issue and working to restore full access as quickly as possible.
Affected services