Back to overview
Downtime

PixelVerseIT Website Temporarily Down

May 28 at 07:25pm AWST
Affected services
PixelVerseIT Website

Resolved
May 29 at 10:10am AWST

We have successfully migrated all PixelVerseIT hompage services.

Updated
May 28 at 07:29pm AWST

The hosting provider transfer for the PixelVerseIT homepage has been completed. We're currently waiting for DNS propagation and are actively monitoring the situation. Some users may still experience temporary access issues during this period.

Created
May 28 at 07:25pm AWST

We are in the process of switching hosting providers for the PixelVerseIT homepage. During this transition, you may experience temporary errors or interruptions. We appreciate your patience.